Forum
Welcome, Guest
Please Login to access forum.
[SOLVED]Error 500 using Responsivizer as standard Template or for mobile display (1 viewing) 
Go to bottom
TOPIC: [SOLVED]Error 500 using Responsivizer as standard Template or for mobile display
#2797
sei lecker! GmbH
Fresh Boarder
Posts: 2
User Offline
[SOLVED]Error 500 using Responsivizer as standard Template or for mobile display Karma: 0  
Dear support,

if i use Responsivizer as standard Template, i get the error "500 - JHtml jyaml not found." (screenshot) on all Devices (Mobile, Desktop) If i use any other Template as standard, i get this error only on mobile devices. The desktop Template for the Website (http://raiffeisen.sei-lecker.de) is based on the Jyaml Template Framework which is already Responsive.

Markus
 
Logged Logged  
  The administrator has disabled public write access.
#2798
John Dagelmore
Admin
Posts: 3885
User Online Now
Re:Error 500 using Responsivizer as standard Template or for mobile display Karma: 84  
Hello Markus,

it looks like the Jyaml Framework installed on Joomla is using some custom JHtml classes to override the default one of Joomla and when another template is used those classes are not loaded, thus the error happening.

I don't know how the Jyaml framework works, if it's based on library or plugin, if you want me to have a look at the backend please contact me at This e-mail address is being protected from spam bots, you need JavaScript enabled to view it

Probably a good choice would be to contact the Jyaml developers to ask some more informations.

John
 
Logged Logged  
  The administrator has disabled public write access.
#2799
John Dagelmore
Admin
Posts: 3885
User Online Now
Re:Error 500 using Responsivizer as standard Template or for mobile display Karma: 84  
PS. i also noticed that the problem is due to the fact that the mod_menu is loaded from the Yaml template despite the fact that the template is the one of responsivizer. Probably this is due to the overrides of the Jyaml framework.
 
Logged Logged  
  The administrator has disabled public write access.
#2802
sei lecker! GmbH
Fresh Boarder
Posts: 2
User Offline
Re:Error 500 using Responsivizer as standard Template or for mobile display Karma: 0  
Thank you very much for your quick reply!
I solved the Problem, it was the mod_menu loaded from the JYAML template. When i installed Responsivizer i copied the Main Menu, this was a special Menu Module from JYAML, so it was loaded also with Responsivizer and made the conflict. Now i made a new Joomla-Menu-Module and published it on the "responsivizer_menu_top" Position and it works.
 
Logged Logged  
  The administrator has disabled public write access.
Go to top