Hi,
your problem is completely different.
Assuming that you are installing the correct package of Responsivizer on your Joomla and you are NOT using Joomla 1.5 (the package installed is for Joomla 2.5+), the problem is due to the old version of PHP running on the server. The error means that you are still running PHP 5.2
If you can't update at least to PHP 5.3 contact me at
This e-mail address is being protected from spam bots, you need JavaScript enabled to view it
and i will send you a custom package.
John