J!Extensions Store™
Forum
Welcome, Guest
Please Login to access forum.
400 error on Google sign in - one solution (1 viewing) 
Go to bottom
TOPIC: 400 error on Google sign in - one solution
#7093
Creative International
Fresh Boarder
Posts: 1
User Offline
400 error on Google sign in - one solution 2 Years, 11 Months ago Karma: 1  
If you get this on a site you have SSL running:

400. That’s an error.

Error: redirect_uri_mismatch

The redirect URI in the request, https://sheruknitting.com/, does not match the ones authorized for the OAuth client. Visit https://console.developers.google.com/apis/credentials/oauthclient/483332312407-v02gve3ufeh5dpe7jv1e49fjfe57g41e.apps.googleusercontent.com?project=483332312407 to update the authorized redirect URIs.

then go to your settings>advanced and look down for

encrypt login form and set to yes.

That solved it for me. Even though I had both http and https in the return API box in my Google credential.

Hope this saves someone an afternoon of angst.

Cheers
 
Logged Logged  
  The administrator has disabled public write access.
#7282
Angus Fox
Fresh Boarder
Posts: 1
User Offline
Re:400 error on Google sign in - one solution 2 Years, 10 Months ago Karma: 0  
thank you. I also had to remove the http:// URI redirects (i had both http and https) in order to make it work.

Angus
 
Logged Logged  
  The administrator has disabled public write access.
Go to top