J!Extensions Store™
Forum
Welcome, Guest
Please Login to access forum.
Re:Problem with Image XML (1 viewing) 
Go to bottom
TOPIC: Re:Problem with Image XML
#642
Computersysteme Gmeiner GmbH
Fresh Boarder
Posts: 3
User Offline
Problem with Image XML 5 Years, 9 Months ago Karma: 0  
Hello Community,

we have a problem regarding xml sitemap generation. No image is recognized and the sitemap is empty. All other "normal" sitemaps are shown correctly. I tried to handle with cache and the options for "include" and "exclude" but I had no success.

What am I doing wrong?

I use Joomla 2.5.23 an JSitemap 2.3.3 Pro.

Greets
C. Gmeiner
 
Logged Logged  
  The administrator has disabled public write access.
#643
John Dagelmore
Admin
Posts: 3556
User Offline
Re:Problem with Image XML 5 Years, 9 Months ago Karma: 74  
Hello,

if the images sitemap is empty, it could mean that the crawler is not allowed at server level.
The hosting could have disabled loopback connections for security reason, in this case the sitemap crawler could receive an empty response.



Greetings

John Dagelmore
 
Logged Logged  
 
Last Edit: 2019/01/14 15:15 By @store$eco#mm!.
  The administrator has disabled public write access.
#644
Computersysteme Gmeiner GmbH
Fresh Boarder
Posts: 3
User Offline
Re:Problem with Image XML 5 Years, 9 Months ago Karma: 0  
Thanks für Your quick reply.

Is it possible to run the crawler on the command line in linux? What do You mean with "loopback" exactly?
 
Logged Logged  
  The administrator has disabled public write access.
#645
John Dagelmore
Admin
Posts: 3556
User Offline
Re:Problem with Image XML 5 Years, 9 Months ago Karma: 74  
I had a couple of users that experimented a similar issue.

Investigating on it, the reason discovered was that the hosting provider didn't allow
php file open from script running on the same server (this is called loopback)

Basically the sitemap crawler needs to open socket to urls of your site and scan to find images.
If the response is empty or a captcha page is sent by server the crawler won't work.
 
Logged Logged  
  The administrator has disabled public write access.
#648
Computersysteme Gmeiner GmbH
Fresh Boarder
Posts: 3
User Offline
Re: [SOLVED] Problem with Image XML 5 Years, 9 Months ago Karma: 0  
I think this was the trick. The apache configuration denied connections from localhost and the local ip addresses. Now it seems to work.

Thank You!
 
Logged Logged  
  The administrator has disabled public write access.
#649
John Dagelmore
Admin
Posts: 3556
User Offline
Re: [SOLVED] Problem with Image XML 5 Years, 9 Months ago Karma: 74  
Thanks to post this to other users

Cheers!
 
Logged Logged  
  The administrator has disabled public write access.
Go to top