J!Extensions Store™
Forum
Welcome, Guest
Please Login to access forum.
Re:JSitemap configuration are not saving (1 viewing) 
Go to bottom
TOPIC: Re:JSitemap configuration are not saving
#7367
Finn Hyttel
Fresh Boarder
Posts: 4
User Offline
JSitemap configuration are not saving 2 Years, 11 Months ago Karma: 0  
Hello,

I bought a new JSiteMap Subscription today and upgraded our old one at our live site.

I started to configure JSiteMap at our live site but when I want to save configuration it it not saving.

I looked this problem up at JextesionStore in their forum and found that it should be down to that the SSL prevent GoogleBot from working. This is far over my head so I kindly ask SiteGround to help me out.

Here is a link to the Forum treads; https://storejextensions.org/forum/view/10-jsitemap/5948-two-problem-sitemap-and-configuration.html

Please find below the replies from SiteGroup Support;

As I can see your SiteMap was generated here:
https://www.xxxxxx.com/index.php?option=com_jmap&view=sitemap

XML format of the SiteMap can be accessed here:
https://www.xxxxxx.com/index.php?option=com_jmap&view=sitemap&format=xml

You can submit your Sitemap to Google bot by following this tutorial:
https://support.google.com/webmasters/answer/183668?hl=en

I have also checked your access logs for any crawl attempts from Google bot. As I can see Google bot can reach your website https://www.xxxxxxx.com:
Code:

66.249.79.153 - - [24/Jun/2017:02:19:12 -0500] "GET /da/events-global/members-events/date/2016-11 HTTP/1.0" 200 65 "-" "Mozilla/5.0 (compatible; Googlebot/2.1; +http://www.google.com/bot.html)"
66.249.93.24 - - [24/Jun/2017:02:19:42 -0500] "GET /index.php/ HTTP/1.0" 200 26715 "-" "Mozilla/5.0 (compatible; Google-Site-Verification/1.0)"
66.249.93.24 - - [24/Jun/2017:02:19:42 -0500] "GET /index.php/ HTTP/1.0" 200 26717 "-" "Mozilla/5.0 (compatible; Google-Site-Verification/1.0)"
66.249.79.153 - - [24/Jun/2017:02:21:15 -0500] "GET /about-us/support-center/faq HTTP/1.0" 200 14267 "-" "Mozilla/5.0 (Linux; Android 6.0.1; Nexus 5X Build/MMB29P) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/41.0.2272.96 Mobile Safari/537.36 (compatible; Googlebot/2.1; +http://www.google.com/bot.html)"

It seems that there is no problem between Google bot and your SSL certficate. It seems that everything is working properly you just need to submit your content to Google.

Best Regards,

Milko Nozhchev
Senior Technical Support

Posted On 24 Jun, 2017 02:49 CDT

Hello Milko,

Thanks a lot for checking this out. I am glad that the Google part is working.

Unfortunately, I have still a problem at the configuration of JSiteMap Pro at our admin. The best way to see the problem is by using the three screenshot I have uploaded and also read my comments at the screenshots.

Best regards,
Finn

Milko Nozhchev
Posted On 24 Jun, 2017 03:05 CDT

I was to reproduce the problem, however I was not able to fix it. In this case I would recommend that you contact the support of JSitemap Pro. It seems that this is paid Joomla extension and all paid Joomla extensions have paid support which is quite good according to the comments here:
https://storejextensions.org/extensions/jsitemap_professional.html

Please contact their support for this issue and if we can change something on our end to make this work please update this ticket.

Best Regards,

Milko Nozhchev
Senior Technical Support

Please help me out.

Thank you and best regards,
Finn
 
Logged Logged  
  The administrator has disabled public write access.
#7368
John Dagelmore
Admin
Posts: 3551
User Offline
Re:JSitemap configuration are not saving 2 Years, 11 Months ago Karma: 75  
Hi Finn,

all these statements make no sense to me.

If you are not able to save the configuration in the Joomla backend, the problem could be due to scripts after the update from a previous version.

You may need to clear the browser cache after the update to refresh new scripts. Also take care to use Google Chrome when trying to save the backend JSitemap configuraiton.

If that's not the case, contact me at This e-mail address is being protected from spam bots, you need JavaScript enabled to view it providing an admin account and i will try it at my end.

Maybe you already had a similar issue in the past: https://storejextensions.org/forum/view/10-jsitemap/534-after-upgrade-to-pro-2-3-2-back-end-are-a-mes.html

Best regards,
John
 
Logged Logged  
 
Last Edit: 2017/06/24 10:39 By @store$eco#mm!.
  The administrator has disabled public write access.
#7371
John Dagelmore
Admin
Posts: 3551
User Offline
Re:JSitemap configuration are not saving 2 Years, 11 Months ago Karma: 75  
For other users reading this post, the problem was server related not client side (browser) related.


Indeed it was created a huge amount of Joomla ACL groups and permissions, causing the limit of the PHP POST input vars exceed.

It's required to contact the hosting provider asking to increase the 'max_input_vars' limit, this will allow to save all the permissions ACL fields in a certain component configuration such as that of JSitemap.
 
Logged Logged  
 
Last Edit: 2017/06/24 14:51 By @store$eco#mm!.
  The administrator has disabled public write access.
#7616
Franz Mediaprint
Fresh Boarder
Posts: 1
User Offline
Re:JSitemap configuration are not saving 2 Years, 10 Months ago Karma: 0  
Hi,

I have set the php_value max_input_vars to 10000 and it always didn`t works for me.
I never can save my configuration. What can I do?

Thank you
 
Logged Logged  
 
Last Edit: 2017/08/09 15:06 By ProjektOliver.
  The administrator has disabled public write access.
#7618
John Dagelmore
Admin
Posts: 3551
User Offline
Re:JSitemap configuration are not saving 2 Years, 10 Months ago Karma: 75  
QUOTE:

Indeed it was created a huge amount of Joomla ACL groups and permissions, causing the limit of the PHP POST input vars exceed.


Firstly you need to understand if the issue is the same, in this case you should have a lot of Joomla ACL groups. If this is not your case you could have another problem maybe not server related.
 
Logged Logged  
  The administrator has disabled public write access.
Go to top