J!Extensions Store™
Forum
Welcome, Guest
Please Login to access forum.
Re:Link analyzer answers with 500 Status Code on ALL links (1 viewing) 
Go to bottom
TOPIC: Re:Link analyzer answers with 500 Status Code on ALL links
#7698
Nicola Agostoni - NimaCAD snc
Fresh Boarder
Posts: 4
User Offline
Link analyzer answers with 500 Status Code on ALL links 2 Years, 1 Month ago Karma: 0  
Hi, i'm using amazing JSitemap pro but i cannot understand why i obtain, using Link analyzer, all lines (links) with 500 Status Code on all links and, in Component / Menu Title / menu ID fileds:
- no info available if using WebCrawler engine
- "contnent / Home / 435 " if using BingCrawler engine

Moreover, if a click on the link with this problem i reach the correct page + i genrated a sitemap and submitted it to Google with no so many errors

Can anyone help me to understand ?
Attached a collage of configuration (case BingCrawler) and two described results

Thanks a lot in advance

Nicola
 
Logged Logged  
 
Last Edit: 2017/08/30 19:39 By nagostoni. Reason: attached image resize
  The administrator has disabled public write access.
#7701
John Dagelmore
Admin
Posts: 3518
User Online Now
Re:Link analyzer answers with 500 Status Code on ALL links 2 Years, 1 Month ago Karma: 74  
Hi,

no what you say is incorrect. WebCrawler or BingCrawler engines don't affect the 'no info available or content/Home/435'
The WebCrawler or BingCrawler is only for the indexing status column and info.
The 'no info available or content/Home/435' is only depending on the param 'Links Analyzer working mode', if you choose compat or standard mode.

By the way this is not relevant for your error, you have a server 500 error so most probably it means that the crawler used by the Links Analyzer is blocked at server level.
I suggest to investigate on the server error log and with the hosting provider, in particular if the hosting provider allows loopback connections, otherwise the Links Analyzer won't work.

You can try to switch to the 'Validation type' to 'Asyncronous' so that your server won't get involved.

This is the same reason why you can't get an images sitemap: https://storejextensions.org/forum/view/10-jsitemap/7699-no-images-in-image-sitemap.html

Best regards
 
Logged Logged  
  The administrator has disabled public write access.
#7707
Nicola Agostoni - NimaCAD snc
Fresh Boarder
Posts: 4
User Offline
Re:Link analyzer answers with 500 Status Code on ALL links 2 Years, 1 Month ago Karma: 0  
Hi. Thank you.
Switching to "Asyncronoous" the Link Analyzer seems to work .

We now obtain Status = 200, Validation = OK (green) , only for Indexing Status it show yello icon = "Informations not available"
 
Logged Logged  
  The administrator has disabled public write access.
Go to top